编程语言

img javamxj

图解利用Eclipse3+Lomboz3+Tomcat开发JSP --1.环境

发表于2004/10/13 13:46:00  5029人阅读

我最近看了不少有关Lomboz的资料,发现有不少网友都对这个eclipse插件感兴趣,但苦于入门。感觉有必要把自己学习Lomboz的心得写下来,以便后来人不至于走太多的弯路。
 

一.环境需求:

1. Lomboz的相关资源
   由于这篇文章重点是放在Lomboz上,所以有必要强调一下。lomboz是Eclipse的一个J2EE的插件,它将很多Java应用服务器、J2EE组件和Web应用开发集成到Eclipse中,可以帮助Java开发者使用Eclipse建立、测试、部署J2EE应用。
   
 
 
  
  注意 下载的时候需要下载两个文件,一个是Lomboz3.0.1 一个是emf-sdo-runtime-2.0.0.zip(这个程序也可以从eclipe官方网站上下载最新版本http://www.eclipse.org/emf/
 
   教程和论坛都是属于Lomboz官方网站的,虽然都是英文资料,但是对于学习Lomboz有很大的帮助。对于想真正了解Lomboz的话(当然最好是直接看源码了),英文又过得去,还是应该看看教程和论坛上的资料。
 
 
2. 我的配置
   Winxp SP1,
   JDK 1.4.2-04  可以从SUN官方网站下载
   Eclipse 3.0.1 和语言包
   Tomcat 5.0.28
   Lomboz 3.0.1
 
3. 目录结构
   F:/j2sdk                    JDK目录 
   D:/eclipse                  Eclipse 目录
   F:/java/jakarta-tomcat      Tomcat 5.0.28 目录
   D:/plug-in/lomboz.301       Lomboz目录(我这里是采用links方式安装的,
  
设置环境变量  参考  Eclipse基础--java环境变量设置
 
安装elcipse及语言包    参考  Eclipse基础--安装eclipse及语言包
 
 

 二. 配置开发环境

  打开Eclipse,点击菜单“窗口”->首选项,以下都在“首选项”中配置:
  1. Java->构建路径
   
 
   2. Lomboz
     
 
   3.Lomboz->Server Definitions->Properties
  
 
   
 
4. 切换到主界面,点击“窗口”菜单->定制透视图
  
 
  切换到“命令”菜单
 
 
 5. 配置后的效果
 
 
注意:
    由于Tomcat 5.0.27、5.0.28版本在Lomboz中无法启动,故需要一些修改。
    找到“D:/plug-in/lomboz.301/eclipse/plugins/com.objectlearn.jdt.j2ee_3.0.1/servers”目录(我采用的是links安装方式);如果采用的是直接把Lomboz解压到Eclipse来安装的,那么要找到“eclipse的安装目录/plugins/com.objectlearn.jdt.j2ee_3.0.1/servers”目录。
    这个目录里面都是相关服务器的配置文件,如果有些配置文件用不到,尽管删除,避免造成视觉疲劳。
如,我只留下了几个文件。
   
 
 
 
  先把“tomcat50x.server”文件改名为“tomcat5028.server”(我用的是5.0.28版本),看起来方便。
打开这个文件,做如下修改:
 
 
  
   最后保存即可。


下一节内容:编辑一个JSP实例
图解利用Eclipse3+Lomboz3+Tomcat开发JSP --2.编辑一个JSP实例
阅读全文
0 0

相关文章推荐

img
取 消
img