CSDN博客

img nxyc_twz

ODAC使用指南 (一)ODAC常见问题集

发表于2003/1/29 17:09:00  3543人阅读

分类: ODAC使用指南

 

ODAC使用指南

nxyc_twz@163.com

(一)ODAC常见问题集


             极高速的数据存取,这一点非常诱人。

     可以调节每个执行查询的参数,以优化索引“资源/生产”。

     可以终止长时间执行的查询(不幸的是,这项功能并不被ORACLE的PL-SQL块所支持)。

         完全支持PL-SQL。

     通过存储过程或匿名PL-SQL块(使用参数)得到游标。

     通过存储过程或匿名PL-SQL块得到PL-SQL表。  

     内建了不同的查询支持。

     内建了运行时调试系统。

     简单便利地使用已提供的标准的错误处理机制。

     将应用程序安装到其它计算机的过程非常简单,因为不需要安装和配置BDE。

        要执行使用ODAC设计的应用程序,需要在客户机上安装ORACLE *SQL-NET2.3ORACLE 7.3)或ORACLE NET8客户端。

     如果你购买了ODAC,你就有权利传播任何已编译的、使用ODAC设计的应用程序。但你没有权利传播任何继承自ODAC或使用ODAC源码的组件。你也可以查看License.txt文件。

     你可以通过继承ODAC或使用ODAC源码来创建你自己的组件. 你有权利传播和销售(已编译的窗体)自己设计的应用程序,比如组件,但不是组件自己。你可以查看License.txt文件。

     为了编译你创建在标准query组件之上的包,你需要ODAC的运行包ODAC.dcp。

      在你已经会费注册的情况下,如果ODAC的主版本与当前版本不同,你就需要再会费。比如, 从ODAC 1.70 升级到 ODAC 1.85 是免费的, 但升级 ODAC 2.00版则要收费。注册的价格是29美元,免费提供技术扶持。

      ODAC的源码包含ODAC除了SQL设计模块以外的所有模块的源码, SQL设计器以DCU文件的方式提供。SQL设计器仅是在ODAC设计过程中使用,因此就并需要它的源码。

     ODAC不支持其它的数据系统,也不能创建多平台的应用程序。 

      为了在ORACLE以前的版本上使用ODAC,需要在客户机上安装 Oracle 7.3和Oracle 8 的SQL-Net2.3。非常抱歉,如果已经安装了其它版本的 *SQL-Net ,所有的设置 (包括数据库别名)都将丢失。为了保存这些设置, 我们建议您重新安装(安装) 包含在 Oracle 7.3中的Oracle调用接口 , 以作为 Oracle *SQL-Net的替代品。 这样的更改将不影响任何其它已经安装的设置,这是实现ODAC功能所必须的。

《未完待续》

0 0

相关博文

我的热门文章

img
取 消
img