编程语言

img pwlazy

fedora9下安装vpn client

发表于2008/10/1 23:40:00  1817人阅读

 在fedora9下安装vpn client还真不容易
通过查资料发现,安装有两种方式,一种是通过NetManager-vpnc,另一种是通过pptpconfig

起初我准备通过pptpconfig的方式,但后来发现pptpconfig并不能通过yum直接安装(网上说可以),如果不通过yum,就得牵扯到很多rpm,于是放弃,走第一条线路,因为netmanager在f9中是现成的,就在桌面的顶端,于是按照文档安装了NetManager-vpnc,以为就好了,但始终连不上server,我也查了很多文档,也有人遇到我这样的问题,但没人给出最终的解决,后来有人提示说可以通过命令行来调试,于是我也如法炮制,看日志信息,查google,也发现有人遇到我这种情况但同样没有解决,不得已只有找官方文档看,官方文档对vpn的介绍非常简短,更不要提解决我的问题,折腾了两天,实在没办法了,只有走第二条路线了,总算是成功了

记录如下:

0)
  1. yum install pptp
1)
  1. wget http://pptpclient.sourceforge.net/yum/stable/fc9/i386/pptpconfig-20060821-1.fc9.noarch.rpm
  2. rpm -ivh pptpconfig-20060821-1.fc9.noarch.rpm
出错
  1. warning: pptpconfig-20060821-1.fc9.noarch.rpm: Header V3 DSA signature: NOKEY, key ID 862acc42
  2. error: Failed dependencies:
  3.     /bin/php4-pcntl is needed by pptpconfig-20060821-1.fc9.noarch
  4.     php4-pcntl >= 4.3.9-2 is needed by pptpconfig-20060821-1.fc9.noarch
  5.     php4-pcntl-gtk is needed by pptpconfig-20060821-1.fc9.noarch
于是:
1.1)
  1.  wget http://pptpclient.sourceforge.net/yum/stable/fc9/i386/php4-pcntl-4.4.9-1.fc9.i386.rpm
  2. rpm -ivh php4-pcntl-4.4.9-1.fc9.i386.rpm
1.2)
  1. wget http://pptpclient.sourceforge.net/yum/stable/fc9/i386/php4-pcntl-gtk-1.0.2-4.fc9.i386.rpm
出错信息:
  1. warning: php4-pcntl-gtk-1.0.2-4.fc9.i386.rpm: Header V3 DSA signature: NOKEY, key ID 862acc42
  2. error: Failed dependencies:
  3.     gtk+ >= 1.2.6 is needed by php4-pcntl-gtk-1.0.2-4.fc9.i386
  4.     libgdk-1.2.so.0 is needed by php4-pcntl-gtk-1.0.2-4.fc9.i386
  5.     libglade.so.0 is needed by php4-pcntl-gtk-1.0.2-4.fc9.i386
  6.     libglib-1.2.so.0 is needed by php4-pcntl-gtk-1.0.2-4.fc9.i386
  7.     libgmodule-1.2.so.0 is needed by php4-pcntl-gtk-1.0.2-4.fc9.i386
  8.     libgtk-1.2.so.0 is needed by php4-pcntl-gtk-1.0.2-4.fc9.i386
  9.     libxml.so.1 is needed by php4-pcntl-gtk-1.0.2-4.fc9.i386
于是
1.2.1)
  1. yum install gtk+
然后再次1.2)发现:
  1.  rpm -ivh php4-pcntl-gtk-1.0.2-4.fc9.i386.rpm 
出错信息:
  1. warning: php4-pcntl-gtk-1.0.2-4.fc9.i386.rpm: Header V3 DSA signature: NOKEY, key ID 862acc42
  2. error: Failed dependencies:
  3.     libglade.so.0 is needed by php4-pcntl-gtk-1.0.2-4.fc9.i386
  4.     libxml.so.1 is needed by php4-pcntl-gtk-1.0.2-4.fc9.i386
于是
1.2.2)
  1. yum install libglade
然后再次
  1. rpm -ivh php4-pcntl-gtk-1.0.2-4.fc9.i386.rpm
终于ok

回到1)
  1. rpm -ivh pptpconfig-20060821-1.fc9.noarch.rpm  
ok

此时传说中的应用程序--》internet-->pptp client终于出现

点击弹出一个简陋的窗口,然后我配置了一下,就像在windows中一样,输入Name,Server,Username,Password,将Domain置为空,终于可以连上公司的vpn了

后来发现只能连上vpn server,vpn 内部网络连不上
原来pptpconfig的route配置默认为client to Lan ,如果改成 All to Lan就ok了
client to Lan 和 All to Lan两种情况下默认路由明显不一样,
前者默认情况下只能连上vpn server除非你自己再设置添加路由记录(可通过pptpconfig的edit network routes或者直接命令行route来设置)
后者所有的外部网络均通过vpn server

如果选择看你自己的情况了



阅读全文
0 0

相关文章推荐

img
取 消
img