CSDN博客

img shaokun305

Eclipse启动遇到的问题获得解决

发表于2004/9/22 9:40:00  2061人阅读

分类: 个人日记 Java

        昨天晚上重新安装了操作系统,原因是因为eclipse不能使用,只有自己的jb7和jb9能够使用。当然游戏也能玩,所以重新安装了操作系统,装完后安装jdk1。4。2。安装后,在系统环境变量中设置了java_home和classpath.完成后,打开eclipse能够使用。很高兴,这个东西这次终于可以使用了,于是开始安装jb7和jb9,但不知道为什么,安装jb9后,jb9自带的tomcat服务器仅仅只有tomcat3.3,郁闷这根本不能使用。于是把jb7下的tomcat文件夹拷贝到jb9的默认目录下,终于tomcat4。0可以使用了。很不错。打开eclipse,可以使用。高兴啊。安装其他软件,一切顺利。折腾到0:30
睡觉了。
       上了一天班,晚上回来,打开eclipse。竟然弹出对话框,报告说没有发现java2。运行环境。气人啊。明明java运行正常。继续提示说:

于是怀疑是c:/windows/system32下的java.exe损坏了,于是把安装的jdk下的java.exe拷贝过来不管用。很郁闷。于是从装jdk。装完后依旧如此。
更加纳闷了。eclipse这个该死的家伙。也太弱了。fake。重新拷贝jdk下的java.exe和java.dll文件到system32下,仍然不行。于是一气之下,
打开命令行窗口,进入到C:/WINDOWS/system32>。之下java命令,系统显示:
C:/WINDOWS/system32>java
Registry key 'Software/JavaSoft/Java Runtime Environment/CurrentVersion'
has value '1.3', but '1.4' is required.
Error: could not find java.dll
Error: could not find Java 2 Runtime Environment.

       系统提示好像是在注册表中找到的是java1.3,而这个java.exe。是java1.4。好像找到问题的所在了,于是,进入注册表。查找到:Java Runtime Environment
看到了他下面却实有好多的jdk版本。包括jb7带的1.3。还有jb9带的1.4.1。还有我刚装的jdk1.4.2。都在,而看到
CurrentVersion的值竟然是1.3。该死,于是改成1.4。保存。在命令行的C:/WINDOWS/system32下运行java。成功了。
       于是打开eclipse。ok。一切成功。终于看到了那个期望的界面。
这个问题可能是jb7的自带jdk1.3所造成的。看来eclipse寻找的jdk不是系统环境变量中的java_home。而是system32下的java虚拟机。也就是
注册表中的那个Java Runtime Environment/CurrentVersio。这次终于从根本上解决了这个恼火的问题。高兴。

       另外一种情况就是eclipse倾动报错,看log文件说,javax的parexml类有问题,该原因一般是因为安装了oracle9i,它在系统变量的path路径中加入了jre1.3的路径,把它删除即可启动eclipse,这主要是因为eclipse使用的jdk.1.4以上的版本,而1.4对1.3做了很大的修改,所以找不到那个类.

0 0

相关博文

我的热门文章

img
取 消
img