综合

img ycool1984

Cisco IOS 基本命令集

发表于2004/9/15 23:25:00  5256人阅读

分类: ╲╱其他COOL资料╲╱

一、 基本路由器的检验命令
show version
show processes
show protocols
show mem
show ip route
show startup-config
show running-config
show flash
show interfaces
二、 基本路由配置命令
进入:config terminal/memory/network
配置网络时常采用的命令:copy和load
1. 标识:hostname 标识名
2. 启动标识:banner 启动标识
3. 接口:interface 端口号
4. 密码:line 0 6
login
passwd 口令
enable password/secret 口令
5. 接口:
1)配置端口
interface 端口号
clock rate 时钟速率(64000)/* 在串口中配置 */
bandwidth 带宽(缺省56) /* 在串口中配置 */
media-type 介质类型 /* 在以太网口上 */
early-token release /* 在令牌环网口上 */
ring-speed 16 /* 在令牌环网口上 */
no shutdown
write memory
2)检验端口
show interfaces
show controllers
6. 配置环境
1) 引导方式
boot system flash IOS-filename
boot system tftp IOS-filename tftp-address
boot system rom
2) 配置Register值
config-register 0x2102
7. 查看邻居路由
show cdp interface
show cdp neighbors [detail]
show cdp entry routerA
8. IP Address 配置
Ip address 网络地址 掩码
Ip host 主机名 address
Ip name-server 服务器地址1 服务器地址2 。。。
Ip domain-lookup nsap
Show hosts
Ping 主机名/IP地址
Trace 主机名/IP地址
三、 IP 路由
1. 静态路由
ip routing
ip route 目标网络号 掩码 端口号 [permanent]
2. 缺省路由
ip default-network 网络号
3. 动态路由
1) RIP配置
Router rip
Network 网络号
Show ip route
Show ip protocol
Debug ip
2) OSPF 配置
Router ospf 进程号
Redistribute 其它路由协议
Network 端口网络 反掩码 area 区域号
Area 区域号 range 网络号 掩码
Area 区域号 default-cost 花销值
Ip ospf priority number
Ip ospf cost 花销值
Show ip ospf database
3) BGP 配置
Router bgp 自治域号
Redistribute 其它路由协议
Network 网络号 /* 自治域内 */
Aggregate-address 网络号 掩码 summary-only 汇总网络
Neighbor 相邻网络号 remote-as 自治域号 /* 自治域间的网络 */
四、 流量控制
1) 被动端口
passive interface 端口号
2) 缺省路由
ip default 网络号/端口网络
3) 静态路由
ip route 目标网络号 掩码 端口号
4)ACL过滤表
(全局上) access-list 访问号1 {permit|deny} 反掩码号 [ established]
access-list 访问号2 {permit|deny} IP/TCP协议 源网络 目的网络
操作符 参数
(端口上)access-group 访问号 in|out
distribute-list 访问号 in|out 端口号
4) Null 0 interface
Ip route address mask null 0
五、 广义网配置
1) PPP
Ppp pap sent-usename 封装
Ppp chap hostname
Ppp chap password
2)X.25
encapsulation x25 [dce]
x25 address
x25 map 协议地址 /*SVC */
x25 pvc pvc号 ip地址 x25地址 /*PVC */
ip switching
x25 route x.121地址 接口 x.121映射地址
2) FrameRelay
Frame-relay local-dlci IP网络号
Frame-relay map 协议地址
Frame-relay lmi-type ansi
 cisco的异步回拨命令集
关键词:
ARA : AppleTalk Remote Access
global configuration : 全局配置模式, conf t 进入.
TACACS +: Terminal Access Controller Access Control System Plus
异步回拨命令:
 
arap callback
callback forced-wait
ppp callback
script arap-callback
script callback
service exec-callback
 
异步回拨命令
这一章描述了用于配置Cisco IOS回拨异步设备的命令集.例子可参考 "Dial
Solutions Configuration Guide " 中的"Configuring Asynchronous callbac
k" 一章.
 
1.arap callback
用于 enable 一个ARA client 回拨请求, 在global configuration下使用.
语法描述:
此命令没有参数和关键词.
默认状态:
回拨默认为不允许.
使用指导:
此命令首先出现在Cisco IOS 11.1中. enable 路由器接受ARA客户端的回拨请求
 
首先必须enable AppleTalk routing,然后在line 上enable automatic ARA st
artup.你能在局域用户鉴定或TACACS+中使用这个命令.
相关命令:
arap authentication
autoselect ara
callback forced-wait
ppp authentication
ppp callback
service exec-callback
username
 
2.callback forced-wait
用于命令Cisco IOS 在回拨客户端前等待一段时间.在global configuration下
使用
语法描述:
此命令没有参数或关键词.
默认:
等待时间没有设置.
使用指导:
此命令首先出现在 Cisco IOS 11.1中.用这个命令使路由器在验证好用户并断
线后,在开始拨号前等待一段时间.
相关命令:
arap callback
chat-script
debug callback
ppp callback
service exec-callback
username
3.ppp callback
用于使一个ppp客户端能拨入异步口并要求回拨.在异步口配置模式下使用.
ppp callback {accept | initiate}
语法分析:
accept : 接受RFC1570-兼容的ppp客户端发来的回拨请求
initate: 接受非RFC1570兼容的ppp客户端发来的回拨请求
默认:
异步口回拨请求默认为不接受
相关命令:
arap callback
autoselect ppp
callback-forced-wait
ppp authentication
username
4.script arap-callback
指定一个用于ARA客户端回拨的脚本,在line 配置模式下使用,用no命令disnab
le.如:
script arap-callback regexp (regexp 是参数)
no script arap-callback
语法分析:
regexp 是一个关于modem拨号的脚本,名字与regexp相同的第一个脚本将被使用
.
默认:
没有脚本分配给终端线.
使用指导:
此命令首先出现在Cisco IOS 11.1中.这个命令指定了回拨ARA客户端的拨号脚本
,用cchat script 命令创建拨号脚本, script arap-callback 命令仅作用于物理
终端(TTY)线上,在虚拟终端(VTY)线上不起作用.配置例子如下:
line 4
script arap-callback usr4
其中usr4是一个拨号脚本.
相关命令:
chat-script
script activation
script callback
script connection
script dialer
script reset
script startup
start-chat
5. script callback
用于指定一个向客户端回拨的脚本.在line配置模式下使用,用no移除.
script callback regexp
no script callback
其他与 script arap-callback同.
6. service exec-callback
用于向exec级的用户回拨。没有参数。
相关命令:
arap callback
callback forced-wait
debug callback
debug confmodem
ppp callback
username
 show,ping,trace&debug 命令介绍
show命令:
 
show interface---显示接口统计信息.
 
一些常用的show interface命令:
 
show interface ethernet
 
show interface tokenring
 
show interface serial
 
show controllers---显示接口卡控制器统计信息.
 
一些常用的show controllers命令:
 
show controllers cxbus
 
show controllers e1
 
show running-config---显示当前路由器正在运行的配置.
 
show startup-config---显示存在NVRAM配置.
 
show flash---Flash memory内容.
 
show buffers---显示路由器中buffer pools统计信息.
 
show memory---路由器使用内存情况的统计信息,包括空闲池统计信息.
 
show processes---路由器活动进程信息.
 
show version---显示系统硬件,软件版本,配置文件和启动的系统映象.
用 debug 命令
 
在超级用户模式下的debug命令能够提供端口传输信息,节点产生的错误消息,诊断
协议包和其它有用的troubleshooting数据.
 
注意:使用debug命令要注意,它会占用系统资源,引起一些不可预测现象.终止使
用debug命令请用no debug all命令.
 
Debug命令默认是显示在控制台端口上的,可用log buffer命令把输出定向到buff
ers里面.若是telnet过去的,可用Router#terminal monitor监控到控制台信息.
用ping命令
 Ping确定网络连通.
用 trace 命令
Trace命令跟踪路由器包传输.
 CISCO远程访问服务器DTE和DCE的连接
发信人: ymllb (), 信区: CISCO
标? 题: CISCO远程访问服务器DTE和DCE的连接
发信站: 网易虚拟社区 (Wed Jun 16 13:10:08 1999), 站内信件

一、在CISCO远程访问服务器中,用三对线连接DTE和DCE,每对线中,一条发送,
一条接收:
??? 1、TX/RX 数据传输线路
?????? 发送:DTE->TX->DCE
?????? 接收:DTE<-RX<-DCE
???? DCE设备(MODEM)通过RX发送数据给DTE,通过TX接收来自DTE的数据,发送
接收的速率在MODEM上设置。通过RS232连接的MODEM与路由器速率必须一致。

??? 2、RTS/CTS 硬件流控
?????? DTE->RTS->DCE
?????? DTE<-CTS<-DCE????????
???? 当DTE数据缓存满,将降低RTS信号,通知DCE不要在发送数据,同理,DCE将
降低CTS信号,通知DTE不要在发送数据。MODEM与访问服务器必须设置为硬件流控

??? 3、DTR/DCD MODEM控制
?????? DTE->RTS->DCE
?????? DTE<-DCD<-DCE????????
???? 当远程访问服务器(DTE)READY,DTR输出信号为高,通过将DTR信号降低,
远程访问服务器挂断线路。MODEM通过DCD信号通知DTE,显示有一拨号拨入,需远
程访问服务器提供服务,MODEM的DCD信号消失,表示MODEM丢掉该次拨号。
Cisco 路由器寄存器配置
发信人: robert_zhao (猫米), 信区: CISCO
标? 题: Cisco 路由器寄存器配置
发信站: 网易虚拟社区 (Thu Jun 10 10:52:56 1999), 站内信件

?


配置目的:寄存器配置用于更改路由器启动过程。

启动位由4位16进制寄存器组成

格式:0xABCD
赋值范围从0x0到0xFFFF

0x2102 :工业默认值
0x2142 :从FLASH中启动,但不使用NVRAM中的配置文件(用于口令恢复)
0x2101 :从Boot RAM中启动,应用于更新系统文件
0x2141 :从Boot RAM中启动,但不使用NVRAM中的配置文件
其中C位的第三位为1时表示关闭Break键,反之表示打开Break键。
0x141:表示关闭Break键,不使用NVRAM中的配置文件,并且从系统默认的ROM中
的系统中启动。
0x0040:表示允许路由气读取NVRAM中的配置文件。

监视命令功能
o:以位的形式显示实际配置的当前起作用的寄存器,
o Displays the virtual configuration register, currently in effect, wi
th a description of the bits?
o/r:重置实际配置的寄存器为以下值:
?9600 (端口速率)
?Break是否有效
?是否忽略NVRAM中的配置
?是否从ROM 中启动
如:o/r 0x2102

表B-1 寄存器配置定义表

位顺序 十六进制 意义?
00 to 03 0x0000 to 0x000F 启动字段?
06 0x0040 使得系统软件忽略NVRAM中的内容
07 0x0080 OEM位开启?
08 0x0100 Break键关闭
10 0x0400 IP广播到所有域
11 to 12 0x0800 to 0x1000 Console口速率
13 0x2000 如果网络启动失败,默认从ROM中启动
14 0x4000 IP broadcasts do not have net numbers??
15 0x8000 启动诊断信息同时忽略NVRAM内容

(1)工业默认寄存器位 0x2102。这个只有以下几个部分组成
bit 13 = 0x2000, bit 8 = 0x0100, and bits 00 到 03 (参照 TableB-2) = 0
x0002.?
表 B-2 启动为注视 (配置寄存器位 00 到 03)??

启动位的意义
0x0:启动后停留在bootstrap状态
0x1:从 ROM 中启动
0x2到0xF:指定默认的启动文件启动系统,?

表B-3 Console口速率设定表

速率 12位 11位
9600 0 0?
4800 0 1?
1200 1 0?
2400 1 1?
路由器初始配置向导.
 
一、路由器开机初始序列
 
当路由器进行初始化时,路由器进行以下操作:
1)自ROM执行上电自检,检测CPU,内存、接口电路的基本操作。
2)自ROM进行引导,将操作系统装下载到主存。
3)引导操作系统由配置寄存器的引导预确定由FLASH 或网络下载,则配置文件的
boot system 命令确定其确切位置。
4)操作系统下载到低地址内存,下载后由操作系统确定路由器的工作硬件和软件
部分并在屏幕上显示其结果。
5)NVRAM中存储的配置文件装载到主内存并通过执行,配置启动路由进程,提供接
口地址、设置介质特性。如果NVRAM中设有有效的配置文件,则进入Setup 会话模
式。
6)然后进入系统配置会话,显示配置信息,如每个接口的配置信息。
 
二、Setup会话
当NVRAM里没有有效的配置文件时,路由器会自动进入Setup会话模式。以后也可
在命令行敲入Setup进行配置。
Setup 命令是一个交互方式的命令,每一个提问都有一个缺省配置,如果用缺省
配置则敲回车即可。如果系统已经配置过,则显示目前的配置值。如果是第一次
配置,则显示出厂设置。当屏幕显示 "------ More ------",键入空格键继续;
若从Setup 中退出,只要键入Ctrl-C即可。
 
1、Setup主要参数:
配置它的一般参数,包括:
主机名 :hostname
特权口令 :enable password
虚终端口令 :virtual terminal password
SNMP网管 :SNMP Network Management
IP :IP
IGRP路由协议:IGRP Routing
RIP路由协议 :RIP Routing
DECnet : DECnet . 等
 
其中 Console 的secret、 password的设置:
enable secret
enable password
Virtual Terminor 的password的设置:
Line vty
Password
Host name的设置:
Hostname
 
2、Setup接口参数:
设置接口参数,如以太网口、TokenRing口、同步口、异步口等。包括IP地址、子
网屏蔽、TokengRing速率等。
 
3、Setup描述:
在设置完以上参数后,该命令提示是否要用以上的配置,如果回答是"YES"则系统
会存储以上的配置参数,系统就可以使用了。
 
4、 Setup相关命令:
Show config
write memory
write erase
reload
setup
 
5、路由器丢失PASSWORD的恢复
以下办法可以恢复:
enable secret password (适合10。3(2)或更新的版本)
enable password
console password
通过修改Configuration Register(出厂为0x2102),使路由器忽略PASSWORD,这
样就可以进入路由器,就可以看到enable password和Console password,但ena
ble secret password以被加密,只能替换。可以进入的configuration Registe
r值为0x142.
 
· 运行password恢复可能会使系统DOWN掉一个半小时;
· 将Console terinal连在路由器的Console口上,确认终端设置为9600bps、8
Data bit 、No parity、1 stop bit;
· show version显示Configuration Register 0x2102;
· 关机再开,按"Ctrl+ Break",进入ROM MONITOR状态,提示符为">";
· 键入"> o/r 0x142",修改 Configuration Register到0x142,可以忽略原先的
password;
· 键入"> initialize",初始化路由器,等一段时间后,路由器会出现以下提示

"system configuration Diaglog ……"
Enter "NO"
提示"Press RETURN to get started!" ,Press "Enter"
· 进入特权模式
Router>enable
Router#show startup-config
这样就可以得到password(enable&console password)
· 修改password
"Router#config ter"
"Router(config)# enable secret cisco"
"Router(config)# enable password cisco1"
"Router(config)# line con 0"
"Router(config)# password cisco"
"Router(config)# config-register 0x2102"
"ctrl + Z"
"Router#copy running-config startup-config"
"reload"
· 以password cisco进入特权用户。
 
三、路由器配置
1)路由器模式
在Cisco 路由器中,命令解释器称为EXEC,EXEC解释用户键入的命令并执行相应
的操作,在输入EXEC命令前必须先登录到路由器上。基于安全原因,EXEC设置了
两个访问权限:用户级和特权级,用户级可执执行的命令是特权级命令的子集。
在特权级,可以使用:configuration,interface,subinterface,line,rout
er,router-map等命令。
 
2)配置模式
使用Config命令可进入配置模式,进入该模式后,EXEC提示用户可用的配置方式
如终端、NVRAM、网络三种,缺省是终端方式。
 
3)IP路由协议模式
在配置模式下输入Router命令,可进入IP路由协议模式,可选的路由协议一般有
:bgp、egp、igrp、eigrp、rip等动态路由和静态路由。
 
4)接口配置模式
在每一个端口上可以设置很多特性,接口配置命令修改以太网、令牌环网、FDDI
或同步、异步口等操作。
 
5)口令配置
可以采用口令来限制对路由器的访问,口令可以设定到具体的线路上或是特权E
XEC模式。
Line console 0 命令设置控制台终端口令
Line vty 0 命令设置Telnet虚终端口令
Enable-password 命令设置特权EXEC访问权限
 
6)路由器命名
在配置模式下用hostname,如:
hostname RouterA
 
四、用户帮助提示
1、在用户提示符下键入?可以列出常用命令,通常有以下命令:
connect 打开一个中端连接
disconnect 关闭一个已有的telnet会话
enable 进入特权级
exit 退出EXEC
help 交互求助系统描述
lock 终端锁定
login 以特定用户登录
logout 退出EXEC
ping 发送echo信息
resume 恢复一个激活的telnet连接
show 显示正在运行的系统信息
systat 显示正在运行的系统信息
telnet 打开一个telnet连接
terminal 设置终端线路参数
where 列出激活的telnet连接
 
2、上下相关帮助
上下相关帮助包括:
符号转换 :键入命令有错时提示;
关键字完成 :键入命令字的一部分即可;
命令记忆 :可用" "调出以前的命令;
命令提示 :当命令记不完全时,可用"?"替代.
 CISCO路由器的基本安装维护
发信人: linuxboy (liuyi), 信区: CISCO
标? 题: CISCO路由器的基本安装维护(转载)
发信站: 网易虚拟社区 (Wed Jul 28 21:05:28 1999), 站内信件

CISCO路由器的基本安装维护
1 控制口连接
先将CISCO2500/1000系列路由器附件中的控制电缆RJ45的一端连接到CISCO的CON
SOLE口上,CISO7000/4000系列路由器则将MODEM电缆的DB25的一端接到CISCO的C
ONSOLE口上,DB9的一端连接到PC的COM1/2上。
在PC上设置仿真终端程序:比如用WINDOWS中的TERMINAL程序,使用COM1/2,960
0BPS,8?
DATA BIT,2STOP?
BIT。其余使用默认值。做好控制口连接后,打开路由器的电源开关。
2 初始安装
一般建议使用机器安装,这样既美观又便于维护。
!!!注意:路由器必须使用带有有效地的电源。一般要求使用的电源的零地间
的电压<4V,零火/地火的电压就为220V。地线保护基本上要求上网的设备需有保
护地线,这些设备包括主机、工作站
、HUB、交换器、路由器及连接路由器的MODEM等。配置路由器的终端或PC机也必
须使用带有有效地的电源。
CISCO的同步串行接口是多用的,通过不同的电缆可引出不同的接口,如RS232、
V.35等。并且CISCO的同步串行接口电缆的电缆是特别预制的。
第一次安装时系统会自动进入DIALOG?
SETUP。依次回答路由器名称,加密超级登录密码,超级登录密码,远程登录密码
,动态路由协议,各个接口的配置等。之后回答YES保存该配置。然后等2分钟,

回车数下。出现路由器名称。打入ENABLE命令,回答超级登录密码。出现路由器
名称#。打入CONFIG?
TERMINAL配置路由器:
NO SERVICE CONFIG
NO IP DOMAIN-LOOKUP
(进一步的配置)
按CTRL-Z退出,出现路由器名称#。打入WRITE?
MEMORY保存配置。
3 一般同步拨号、专线、DDN连接配置
IPX routing IPX routing
INTERFACE SERIAL 0 INTERFACE SERIAL 0
IP ADDRESS 1.1.1.1 255.0.0.0 IP ADDRESS 1.1.1.2.?
255.0.0.0
IPX NETWORK 111 IPX?
NETWORK 111

INTERFACE ETHERNET 0 INTERFACE ETHERNET 0
IP ADDRESS 12.1.1.1 255.0.0.0 IPADDRESS 16.1.1.1?
255.0.0.0
IPX NETWORK 123456 IPX?
NETWORK 987654

ROUTER IGRP 1 ROUTER?
IGRP 1
NETWORK 1.0.0.0 NETWORK 1.0.0.0
NETWORK 12.0.0.0 NETWORK?
16.0.0.0
4 X.25连接配置
IP ROUTING IP?
ROUTING

INTERFACE SERIAL 0 INTERFACE SERIAL 0
IP ADDRESS 1.1.1.1 255.0.0.0 IP ADDRESS 1.1.1.2?
255.0.0.0
ENCAPSULATION X25 ENCAPSULATION X25
X25 ADDRESS 32699 X25 ADDRESS 32688
X25 HTC 16 X25 HTC 16
X25 IDLE?
6 X25 IDLE 6
X25 map ip 1.1.1. 2 32688 broadcast X25 map ip 1.1.1.1??
32699 broadcast

INTERFACE ETHERNET 0 INTERFACE ETHERNET 0
IP ADDRESS 12.1.1.1 255.0.0.0 IP ADDRESS 16.1.1.1 255.0.0.0

ROUTER IGRP 1 ROUTER IGRP?
1
NETWORK 1.0.0.0 NETWORK 1.0.0.0
NETWORK 12.0.0.0 NETWORK 16.0.0.0
5 一般故障判断
首先看MODEM的状态,如果MODEM的DCD不亮,则表示线路连接故障,请先检查线路
连接。
再检查路由器的电缆连接。
将控制终端连接到路由器上。按回车数下,出现路由器名称,打入show??
interface serial 0
观看第一行,line和line protocol的状态:
如果line is?
up,表示路由器接收的该线路接口的DCD信号;否则表示线路接口的DCD信号为低

如果line protocol is?
up,表示该线路接口的线路协议匹配成功。否则表示线路协议匹配失败。
打入show interface ethernet 0
如果line protocol is up,表示该线路接口连接正常。
6 故障检测及排除方法
通信系统在运行中可能出现一些故障,我们如何迅速地找出故障所在,并及时修
改,是维持系统正常运行的关键,下面,我们就端口、线路、链路等方面,提供
一些参考方法:
(2)判断以太端口故障:
对于以太端口故障的诊断,我们可以用 show interface?
ethernet 0?
(对于以太端口0的诊断)的命令,它用来检查一条链路的状态,如下所示:
router# show int ethernet 0
EtherNet 0 is up,line protocol is up
: 正常 ===============Ethernet 0 is up,line protocol is up
: 连接故障,路由器未接到LAN上 ======Ethernet 0 is up,line??
protocol is down
: 接口故障 ====== Ethernet 0 is down,line protocol is down(disable)
: 接口被人为地关闭 ===== Ethernet 0 is administratively down,line??
protocol is down(可在配置状态中 interface_mode?
下去掉shutdown命令)。
此外,当我们怀疑端口有物理性故障时,可用 shown?
version,将显示出物理性正常的端口,而出现物理故障的端口将不被显示出来。

(2)判断串行端口故障
当发现与远程的通信中断时,我们应按照下面这个顺序来隔离故障:
线路---*}端口
判断线路是否中断
:DDN线路。查看DTU的指示灯,DTU上共有四种指示灯:Power、Line、DTR、Rea
dy?
。Power灯在DTU上电后应保持长亮,而Line、Ready灯就表示了该DTU与DDN节点机
连接的情况,正常情况下这两个灯也应该长亮。
如果发现有异,应及时与DDN网管中心联系。DTR灯表示DTU与DTE(路由器)的连
接情况,当路由器上电后,若串口状态正常,则DTU上的DTR灯也应保持长亮(当
线路不通时,偶尔闪熄一下)。
:模拟线路。查看MODEM上的指示灯,对于同步专线,一般来说,CD、TD、RD应保
持长亮,当有数据在广域网线路上传输时,TD和RD灯将不停闪烁,当这些灯不正
常时,应与电信部门联系。
(b)判断端口故障:
对于串行端口故障的诊断,我们可以用 show interface serial??
0?
(对于串行端口0的诊断,别的串行端口的诊断类似)的命令,它用来检查一条链路
的状态,如下所示:
router# show int serial 0
Serial 0 is up,line protocol is up
:? Serialt 0 is up,line protocol is up=====正常??
:? serial 0 is up,line protocol is?
down=====端口无物理故障,但上层协议未通(IP、IPX、X25等,请查看路由器的
配置命令,检查地址是否匹配)。
:? Serial 0 is down,line protocol is?
down(disable):端口出现物理性故障,只有更换端口。
:? Serial 0 is down,line protocol is?
down:DCE设备(MODEN/DTU)未送来载波/时钟信号,请与电信部门联系。
:? Serial 0 is administratively down,line protocol is??
down====接口被人为地关闭,可在配置状态中 interface_mode?
下去掉shutdown命令。
此外,当我们怀疑端口有物理性故障时,可用 shown?
version,将显示出物理性正常的端口,而出现物理故障的端口将不被显示出来。


7 一般命令
(=后面的命令是11.0以后提供的等效命令)
enable 进入超级登录
disable 退出超级登录
show config=show start 显示NVRAM的配置
write terminal=show run 显示当前有效的配置
write memory=copy run start 保存当前有效的配置到NVRAM中
write erase 清除NVRAM的配置
show interface serial 0 显示串行接口0的状态
show ip route 显示当前IP路由表
show ipx route 显示当前IPX路由表
show ipx servers 显示当前Ipx服务器表
config?
terminal 从终端上配置路由器,按CTRL-Z退出
ipx routing 在该路由器上激活IPX
interface serial 0 配置同步串行接口0
encapsulation ppp 该接口的线路协议为PPP
ip address 12.1.1.1?
255.0.0.0 该接口的IP地址是12.1.1.1,子网掩码是255.0.0.0
ipx?
nework 123456 该接口的IPX网络地址是123456
router rip 配置路由协议RIP
network 12.0.0.0 该路由协议包括12.0.0.0网络

Cisco 2500系列升级指南
发信人: jadebj (jade), 信区: CISCO
标? 题: Cisco 2500系列升级指南
发信站: 网易虚拟社区 (Wed May 19 10:44:52 1999), 站内信件

?Cisco 2500系列升级指南(使用TFTP SERVER)


1,准备:
? PC机一台,安装网卡,TFTP软件
? PC机一台,运行WINDOWS或WIN95仿真终端程序
2, 步骤:
①? 设备连接:使用Cisco设备所带的Console线(黑色),连接2500的Console口
和PC机的COM口,使用Cisco设备所带的双绞线(灰色),连接2500的AUI口(需要
有AUI-AJ45的收发器)和TFTP SERVER的网卡RJ-45口 。
②? 将升级软件拷贝至TFTP SERVER的相关目录下,启动TFTP SERVER。
③? 在PC机上通过终端仿真方式进入Cisco 2500的控制台
??
在控制台方式下不要进入AUTOINSTALL方式,选择手动配置方式。

④? 在控制台状态下键入:
router>en????????????????????????????????????? {进入特权模式}??????
router#sh flash all?????????????????????????????? {记录system images文
件名}
router#copy flash tftp??????????????????????????? {备份原有system imag
es到tftp server}
?? 按提示输入TFTP SERVER的IP地址
?? 按提示输入SYSTEM IMAGES的文件名
?
router#conf t??????????????????????????????????? {进入全局配置模式}????
????????????????????????????????
router(config)#config-reg 0x2101?????????????????? {修改寄存器值为 210
1}
router(config)#interface e0??????????????????????? {进入以太口配置模式
}
router(config-if)#ip address ##.##.##.## 255.255.255.0? {ip地址应与tft
p server ip在同一网段}
router(config-if)#no shutdown????????????????????? {激活端口}
router(config-if)#^z
router#reload??????????????????????????????????? {重新加载系统}
router(boot)>en
router(boot)#copy tftp flash???????????????????????? {从tftp server升级
IOS软件}
?? 按提示输入TFTP SERVER的IP地址
?? 按提示输入升级IOS源文件名
?? 按提示输入升级IOS目标文件名
?? 回车确认后,系统删除旧的IOS,开始从tftp server向router传输新的IOS文
件.
?? 传输完成后键入:
router(boot)#config t
router(boot)(config)#config-reg 0x2102??????????????? {将寄存器值改回2
102}
router(boot)(config)#^z
router(boot)#reload
CISCO路由器的一般配置与调试
-- 路 由 器 是 计 算 机 网 络 的 桥 梁, 通 过 它 不 仅 可 以 连 通 不 同 的 网 络, 还 能 选 择 数 据 传 送 的 路 经, 并 能 阻 隔 非 法 的 访 问。 路 由 器 的 配 置 对 初 学 者 来 说, 并 不 是 件 容 易 的 事。 现 将 路 由 器 的 一 般 配 置 和 简 单 调 试 介 绍 给 大 家, 供 朋 友 们 在 配 置 路 由 器 时 参 考。
 
---- 一 . CISCO2501、2522 硬 件 结 构
 
---- CISCO 2501 有 一 个Ethernet 网 口(AUI), 一 个Console 口(RJ45), 一 个AUX 口(RJ45), 和 两 个 同 步 串 口, 支 持DTE 和DCE 设 备; 支 持 EIA/TIA-232、 EIA/TIA-449、 V.35 、X.21 和EIA-530 接 口。
 
---- CISCO 2522 有 一 个Ethernet 网 口(AUI), 一 个ISDN BRI 口, 一 个Console 口(RJ45), 一 个AUX 口(RJ45), 两 个 高 速 同 步 串 口,8 个 同 步/ 异 步 底 速 口, 支 持DTE 和DCE 设 备; 支 持 EIA/TIA-232 、EIA/TIA-449、 V.35 X.21 和EIA-530 接 口。
 
---- 二 . 配 置
 
---- 1 . 配 置 以 太 网( Enthernet) 端 口
 
 
# conf t
从终端配置路由器。
# int e0
指定E0口。
# ip addr ABCD XXXX
ABCD为以太网地址,XXXX为子网掩码。
# ip addr ABCD XXXX secondary
E0口同时支持两个地址类型。如果第一个
为A类地址,则第二个为B或C类地址。
# no shutdown
激活E0口。
# exit
2.X.25的配置
# conf t
# int S0
指定S0口.
# ip addr ABCD XXXX
ABCD为以太网S0的IP地址,XXXX为子网掩码.。
# encap X25-ABC
封装X.25协议。ABC指定X.25为DTC或DCE操作,缺省为DTE。
# x25 addr ABCD
ABCD为S0的X.25端口地址,由邮电局提供。
# x25 map ip ABCD XXXX br
映射的X.25地址.ABCD为对方路由器(如:S0)的
IP地址,XXXX为对方路由器(如:S0)的X.25端口地址。
# x25 htc X
配置最高双向通道数.X的取值范围1-4095,
要根据邮电局实际提供的数字配置。
# x25 nvc X
配置虚电路数。X不可超过据邮电局实际
提供的数,否则,将影响数据的正常传输。
# exit
---- 3 . 专 线 的 配 置
 
 
# conf t
# int S2
指定S2口。
# ip addr ABCD XXXX
ABCD为S2的IP地址,XXXX为子网掩码。
# exit
4.帧中继的配置
# conf t
# int s0
# ip addr ABCD XXXX
ABCD为S0的IP地址,XXXX为子网掩码。
# encap frante_relay
封装frante_relay协议。
# no nrzi_encoding
NRZI=NO
# frame_relay lmi_type q933a
LMI使用Q933A标准.LMI(Local management
Interface)有3种:ANSI:T1.617;CCITTY:Q933A和CISCO特有的标准。
# fram-relay intf-typ ABC
ABC为帧中继设备类型,它们分别是DTE设备,
DCE交换机或NNI(网络接点接口)支持。
# frame_relay interface_dlci 110 br
配置DLCI(数据链路连接标识符)。
# frame-relay map ip ABCD XXXX broadcast
建立帧中继映射。ABCD为对方
ip地址,XXXX为本地DLCI号,broadcast
允许广播向前转发或更新路由。
# no shutdown
激活本端口.
# exit
---- 5 . 帧 中 继 子 接 口 的 配 置
 
# conf t
# int s0.1 point-to-point
对应S0的子接口1,点对点方式。
# ip addr ABCD XXXX
ABCD为子口1的IP地址,XXXX为子网掩码。
# frame-relay intreface-dlci 100 br
6.配置拨号备份
(1).配置备份主口
# conf t
# int s0
S0为主口.
# backup int asy 1
A1口为备份口.
# backup delay 0 1
延时1秒.
(2).配置虚拟接口
# conf t
# ip addr ABCD XXXX
ABCD为虚拟接口IP地址,XXXX为子网掩码。
# encap ppp
封装ppp协议.
# dialer in-band
激活随叫随拨功能.
# dialer idle-timeout 7200
# dialer map ip ABCD modem-script call
broadcast 6225481 br 映射对应的拨号口.
 
ABCD为对方拨号口的ip地址,6225481为对应的电话号码。
# dialer_group 1 定义拨号组成员.
(3).配置防火墙
# dialer_list 1 pro ip permit
允许ip协议通过。
(4).配置连接口令
# user name ABCD pass XXXX
ABCD为对方主机名,XXXX为连接口令.
(5).配置拨号字符串
# conf t
# chat-script call ABORT BUSY ABORT ERROR"" atdt
6335481 TIMEOUT 45 "CONNECT"
6335481为对方电话号码。
(6).配置拨号连接密码
# conf t
# username ROU1 pass XXXX
ROU1为对方路由器名,XXXX为连接密码。
(7).配置线路
# conf t
# line aux 0
# modem inout
MODEM双向传输。
# modem autoconfigure discovery
# transport input all
# rxspeed 51200
MODEM的收发速率为51200。
# txspeed 51200
# exit
7.配置同步/异步口 (适用于2522)
# conf t
# int s2
# ph asyn
配置S2为异步口.
# ph sync
配置S2为同步口.
8.动态路由的配置
# conf t
# router eigrp 20
使用EIGRP路由协议。常用的路由协议有RIP,IGRP,IS-IS等。
# passive-interface serial0
若S0与X.25相连,则输入本条指令。
# passive-interface serial1
若S1与X.25相连,则输入本条指令。
# network ABCD
ABCD为本机的以太网地址。
# network XXXX
XXXX为S0的ip地址。
# no auto-summary
# exit
9.静态路由的配置
# ip router ABCD XXXX YYYY 90
ABCD为对方路由器的以太网地址;XXXX
 
为子网掩码.;YYYY为对方对应的广域网端口地址。
# dialer-list 1 protocol ip permail
10.备份配置文件到硬盘
# copy run tftp
在硬盘上建立一个空文件且有读写权限,才能备份成功.
11.恢复备份配置文件到路由器
# copy tftp run
12.在路由器上建一个备份
# copy run start
路由器的配置参数较多,可根据实际需要增减,
限于篇幅,本文仅给出了一般的常用配置。
---- 三 . 调 试
 
---- 1. 首 先 将 路 由 器 的Ethernet 口 和 所 有 要 使 用 的 串 口 都 激 活, 方 法 是 进 入 该 口, 执 行No Shutdown。
 
---- 2. 将 和 路 由 器 相 连 的 主 机 加 上 缺 省 路 由( 中 心 路 由 器 的Ethernet 地 址), 方 法 是 在UNIX 系 统 的 超 级 用 户 下 执 行:router add defaule XXXX 1(XXXX 为 路 由 器 的E0 口 地 址)。 每 台 主 机 都 要 加 缺 省 路 由, 否 则, 将 不 能 正 常 通 讯。
 
---- 3. Ping 本 机 的 路 由 器Ethernet 网 口( 若 不 通:(1)Ethetnet 网 口 没 有 激 活(2) 不 在 一 个 网 上)、 广 域 网 口( 若 不 通: 没 有 加 缺 省 路 由), 对 方 广 域 网 口( 若 不 通: 路 由 器 配 置 错 误)、 路 由 器Ethernet 网 口( 若 不 通: 路 由 器 配 置 错 误)、 主 机Ethernet 网 口( 若 不 通: 对 方 主 机 没 有 加 缺 省 路 由)。
 
---- 4. 在 专 线 卡(X.25) 主 机 上 加 网 关( 静 态 路 由), 方 法 是 在UNIX 系 统 的 超 级 用 户 下 执 行:router add X.X.X.X Y.Y.Y.Y 1。 X.X.X.X 为 对 方Ethernet 网 地 址;Y.Y.Y.Y 为 对 方 广 域 网 地 址。
 
---- 5. 使 用Tracert 对 路 由 进 行 跟 踪, 以 确 定 不 通 网 段。
 WAN的配置资料
这一章我们介绍比较常用的广域网配置及实例,包括DDN专线,X.25,帧中继以及电话拨号网络的配置.在以后我们还将增加ATM等配置.
        概述
配置DDR
配置帧中继
配置DDN
配置X.25
广域网配置实例
 
----------------------------------------------------------------------
----------
 
概述
 
Cisco IOS提供了广阔范围的广域网网络性能,适合于各种网络环境需要.Cisco提
供了信元转播SMDS( Switching Mutilmegabit Data Service),电路交换ISDN( I
ntegrated Services Digital Network),包交换Frame Relay以及兼容电路交换和
包交换好处的ATM( Asynchronous Transfer Mode.局域网仿真( LAN emulation)
提供了ATM和各种局域网类型的连接.
 
Cisco的拨号备份提供了当广域网出现故障时的连接访问.DDR(Dial-on-Demand r
outing)提供了灵活的用Modem或ISDN连接上广域网.拨号连接可以使用链路访问程
序,LAPB,PPP,X.25和帧中继实现.
 
 
 
 
----------------------------------------------------------------------
----------
 
配置DDR
 
Dial-on-demand routing(DDR)是用公共电话网提供了网络连接.通常的,广域网大
多数用专线连接的,路由器连接到类似modem或ISDN TAs的数据终端DCE设备上,它
们支持同步V.25bis协议,你可以用scripts和dialer命令设定拨号串.
 
DDR比较适用于用户对数率要求不高,偶尔有数据传输或只是在特定时候传输数据
,比如银行每晚传送报表等等情况下.
 
当一个感兴趣的包到达路由器时,产生一个DDR请求.路由器发送呼叫建立信息给指
定的串口的DCE设备.这个呼叫就把本地和远程的设备连接起来.一旦没有数据传输
,空闲时间开始计时,超过设置的空闲时间,这一次连接终止.DDR现在都用静态路由
来传输数据包,避免路由交换引起的DDR拨号.
 
AppleTalk,Banyan VINES, CLNS, DECnet, IP, IPX, 和XNS可以通过DDR路由寻址
.同步串口,异步串口和ISDN端口可以配置成到一个或多个目的地DDR连接.
 
 
 
在配置DDR过程中,我们可以把一个或几个物理接口配置成一个逻辑拨号接口,它可
以是同步V.25方式,同步DTR启动拨号或异步chat script方式.
 
在端口配置模式下:
 
功 能 命 令
在一个端口上激活 Dial-on-demand routing dialer in-band
指定一个端口为拨号访问组 dialer-group group-number
指定一个单一电话号码 dialer string dial-string
断线前空闲等待时间 dialer idle-time seconds
定义一个或多个目的电话号码表 dialer map protocol net-hop-address diale
r-string
限定传输的access-list表或特定协议 dialer-list dialer-group list access
-list-number

dialer-list dialer-group protocol protocol-name {permit|deny|list acce
ss-list-number}
 
其中dialer string和dialer map两条命令任选一,dialer string是在只有一个电
话号码时用,而dialer map是一个电话号码表.
 
详细配置说明请参阅下面"DDR Example"的实例.
 
配置拨号备份
 
拨号备份提供了一种保护,使得当广域网上主干线出现故障时,启动一条备份线路
,使通信正常运转.
 
启动备份有两种情况:
 
主干线断掉
 
传输流量超过了定义的最大值
 
需作的定义如下:
 
在主干线路端口上设置它的备份端口 backup interface interface-name
定义备份负载 backup load {enable-threshold | never} {disable-load |nev
er}
定义主干线up或down的响应时间 backup delay {enable-delay | never) {disa
ble-delay | never}
 
其中: enable-threshold --- 表示主干线超过总传输量的百分比,启动备份线路
 
 
disable-load --- 表示传输量减少百分之多少就断开备份线路.
 
enable-delay --- 表示主干线断开多长时间后,启动备份线路.
 
disable-delay --- 表示主干线又重新恢复多长时间后,断开备份线路.
 
详细配置说明请参阅下面"Dial Backup Example"的实例.
 
 
 
 
----------------------------------------------------------------------
----------
 
配置帧中继
 
帧中继是一种由ANSI和CCITT标准化的协议,它能为现今突发性业务流量(如LAN互
连及SNA业务)提供显著的性能价格优势.帧中继是客户端设备(CPE),诸如路由器或
前端处理器,和一个向远程CPE发送数据的广域网之间的一种接口协议.它有以下几
个特点:
 
低时延
时延是指一个给定待发送帧穿过网络到达远程用户设备所用的时间.当网络时延增
大时,性能会下降;尤其对于敏感协议(如SNA和DECnet),所有帧被发送后必须等待
应答的协议(即Novell IPX),以及利用短交易式的应用.
可靠性
在给定时延条件下,吞吐量随着网络的可靠性变化而变化,可靠性好,超时等待重发
帧越少,吞吐量就会大大增加.
 
更低的联网开销
 
可预测性
在许多网络环境中,如SNA CICS,不仅要求时延低,而且需要可预测性.
 
公平性
Cisco's Frame Relay目前支持IP,DECnet,AppleTalk, Xerox Network Service
(XNS), Novell IPX, International Organization for Standards (ISO) Conn
ectionless Network Service (CLNS), Banyan VINES, 和 transparent bridgi
ng在帧中继中传输.
 
 
 
 
配置帧中继的工作表:
 
在一个端口上作帧中继打包
定义动态或静态的地址映射
定义LMI
配置帧中继交换虚电路
帧中继交换
监控帧中继连接
在一个端口上作帧中继打包
 
某一端口上配置帧中继打包走帧中继协议,在global配置模式下:
 
功 能 命 令
指定走帧中继的端口并进入端口配置模式 interface serial number
指定帧中继打包方式 encapsulation frame-relay [ietf]
 
Cisco的帧中继与RFC 1490的打包方式一致,允许不同厂家的产品互相通信.当与其
它厂家路由器连接时,请用IETF打包.
 
定义动态或静态的地址映射
 
动态地址映射
 
动态地址映射用帧中继的翻转ARP协议发送请求下一个希望到达的地址(next hop
protocol address)(假设知道DLCI),当有应答翻转ARP协议请求时,保存在addre
ss-to-DLCI映射表中,这张表就用来提供下一个希望到达的地址或出去的DLCI地址
.
 
翻转ARP协议默认是打开的,故动态地址映射不需要做任何配置.
 
静态地址映射
 
一个静态地址映射是人为的指定下一个希望到达的地址(next hop protocol add
ress)与DLCI的对应关系.当指定了静态地址映射时,翻转ARP协议自动关闭.
 
建立静态地址映射表需完成:
 
功 能 命 令
定义一个端口或子端口的DLCI地址 frame-relay interface-dlci dlci
指定一个next hop protocol address与DLCI之间对应 frame-relay map protoc
ol protocol-address dlci [broadcast] [ietf] [cisco]
 
相应地,关键字protocol支持的协议:
 
IP---ip
DECnet---decnet
AppleTalk---appletalk
XNS---xns
Novell IPX---ipx
VINES---vines
ISO CLNS---clns
如果是一点对一点,可用interface-dlci命令,若是一点对多点则设定 frame-rel
ay map 一系列的dlci与ip address 对应表.
 
定义LMII
 
在Cisco IOS Release 11.2版本以上,支持本地管理接口LMI(Local management
Interface)自动识别,即由交换机端口决定LMI的类型.当然,我们也可以明确配置
LMI类型.
 
功 能 命 令
建立路由器间keepalive时间 frame-relay keepalive number
定义N391的间隔时间 frame-relay lmi-n391-dte keep-exchanges
 
 
 
配置帧中继交换虚电路
 
目前,访问帧中继网是56K到45M数率,帧中继是在两个节点间建立面向连接的,包交
换的虚电路.
 
在一个物理端口上配置SVCs
 
在子端口上配置SVCs
在一个帧中继端口上配置SVC操作
 
功 能 命 令
指定物理端口 interface serial number
如果需要,配置IP地址 ip address ip-address mask
在这个端口上配置帧中继打包 encapsulation frame-relay
在这个端口上激活帧中继SVC frame-relay svc
 
在子端口上配置SVCs
 
功 能 命 令
在主端口上指定一个子端口 interface serial number.subinterface-number {
multipoint | point-to-point}
如果需要,配置IP地址 ip address ip-address mask
 
参阅下面"Configure subinterface Example"的例子.
 
帧中继交换
 
当一个帧中继网要通过IP网与另一个帧中继网互连,就要用到帧中继交换.把IP网
看作帧中继包的隧道通过去.
 
实现帧中继交换,配置如下:
 
功 能 命 令
把路由器作为帧中继交换机 frame-relay switching
在路由器上设置静态路由 frame-relay route in-dlci out-interface out-dlc
i
定义网络功能 frame-relay intf-type {dte| dce| nni}
 
请参阅"Frame Relay Switching Example"配置实例.
 
监控帧中继连接
 
在EXEC模式下:
 
功 能 命 令
显示帧中继DLCI和LMI信息 show interface serial number
显示LMI状态 show frame-relay lmi [type number]
显示PVC状态 show frame-relay pvc [type number [dlci]]
显示配置静态路由 show frame-relay route
显示帧中继传输状态 show frame-relay traffic
 
 
 
 
----------------------------------------------------------------------
----------
 
配置DDN
 
DDN(Digital Data Network)是一种点对点的同步数据通信链路.它支持PPP,SLIP
,HDLC和SDLC等链路层通信协议.允许IP, Novell IPX, Bridging,CLNS,AppleTal
k,DECnet等多种上层协议在上面运行.
 
基本配置
压缩技术
E1端口配置
基本配置
 
功 能 命 令
进入指定端口 interface serial number
定义该端口IP地址 ip address ip-address mask
指定该端口打包方式 encapsulation {PPP| HDLC }
 
压缩技术
 
通常在串口中传输的数据是不压缩的,它允许数据包头在每次传输时正常交换,但
每次将浪费带宽.目前支持的压缩有PPP,Frame Relay, X.25, TCP等等.
 
Cisco的压缩是通过软件完成的,将影响系统性能.故建议路由器CPU占用超过65%,
就不要使用压缩.(show process cpu EXEC命令查看当前CPU使用情况)
 
功 能 命 令
TCP传输头压缩 ip tcp head-compression [passive]
X.25压缩 X25 compress
PPP压缩 ppp compress [predictir|stac]
 
注: "passive"表示只有输入包是压缩时,输出包才压缩.
 
E1端口配置
 
在Cisco 4500,4700,7000和7500系列里面均支持E1(2.048Mbps)数率的接口.每一
个E1端口可以按时隙分成30路64K数据线路和2路信号线路.这30个64K数据线路每
一路均可以当作一条64K的专线.
 
功 能 命 令
在配置模式下,定义Controller E1 controller e1 slot/port
定义line code linecode {ami |hdb3}
定义字符帧 framing {crc4 |no-crc4}
定义E1组 channel-group number timeslots range [speed {48| 56| 64}]
指定串口属于那一个channel-group组 interface serial slot/port:channel-g
roup
 
注:
 
slot/port----是针对7000或7500系列的,故区分槽口号和端口号.
 
linecode----默认是HDB3.
 
framing----默认是crc4,要与电信局参数匹配.
 
channel-group----每个E1可以分成30个channel-group,把channel-group和时间
槽对应起来.channel-group是0-30,timeslots是1-31.
 
interface serial----在定义完E1 channel-group后,我们把group赋予成一个虚
拟串口.
 
具体的请参阅"Channelized E1 Interface Example"实例.
 
 
 
 
----------------------------------------------------------------------
----------
 
配置X.25
 
X.25配置完成如下工作:
 
功 能 命 令
设置X.25模式 encapsulation x25 [dte|dce]
设置最大虚电路数 x25 htc max-vc-number
设置X.121地址 x25 address x121-address
建立IP地址与X.121地址对应 x25 map ip ip-address x121-addres [broadcast
]
 
htc----htc是最大的虚电路数,因为许多X.25交换机是从高到低建立虚电路的,ma
x-vc-number不能超过申请的最大值.
 
请参阅"X.25 Example"的配置实例.
 
 
 
 
----------------------------------------------------------------------
----------
 
广域网配置实例
 
DDR Example
Dial Backup Example
Configure subinterface Example
Frame Relay Switching Example
Channelized E1 Interface Example
X.25 Example
DDR Example
 
 
 
Configuration for RouterA:
 
ip route 131.108.29.0 131.108.126.2
ip route 131.108.1.0 131.108.126.2
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx deny
!
interface serial 0
ip address 131.108.126.1 255.255.255.0
dialer in-band
dialer-group 1
!
dialer map ip 131.108.126.2 5551234
!
dialer idle-timeout 300
 
Dial Backup Example
 
A)同步V.25 bits方式
 
Configuration for RouterA:
 
interface Serial0:0
backup delay 0 10
backup interface Serial10
ip address 16.217.30.2 255.255.255.252
!
interface Serial10
ip address 16.30.16.81 255.255.255.0
encapsulation ppp
dialer in-band
dialer string 8292
dialer-group 1
pulse-time 1
!
dialer-list 1 protocol ip permit
 
B)辅助口作拨号备份
 
Configuration for RouterA:
 
chat-script MYDIAL "" "atdt 8292" TIMEOUT 60 "CONNECT"
!
interface Serial0
backup delay 0 0
backup interface Async1
ip address 16.3.1.1 255.255.255.0
encapsulation ppp
!
interface Async1
ip address 16.3.2.1 255.255.255.0
encapsulation ppp
keepalive 9
async default routing
async dynamic address
async dynamic routing
async mode dedicated
dialer in-band
dialer string 8292
dialer-group 1
!
dialer-list 1 protocol ip permit
!
line aux 0
script dialer MYDIAL
modem InOut
transport output none
stopbits 1
flowcontrol hardware
speed 9600
 
Subinterface Example(Frame Relay)
 
 
 
Configuration for RouterA:
 
interface serial 0
encapsulation frame-relay
interface s 0.1 multipoint
ip address 11.10.11.1 255.255.255.0
frame-relay interface-dlci 41
frame-relay interface-dlci 42
 
Configuration for RouterC:
 
interface serial 0
encapsulation frame-relay
interface s 0.1 point-to-point
ip address 11.10.16.2 255.255.255.0
frame-relay interface-dlci 46
 
Configuration for RouterB:
 
interface serial 0
encapsulation frame-relay
interface s 0.1 multipoint
ip address 11.10.11.3 255.255.255.0
frame-relay interface-dlci 43
frame-relay interface-dlci 44
!
interface s 0.2 point-to-point
ip address 11.10.13.1 255.255.255.0
frame-relay interface-dlci 48
 
Frame Relay Switching Example
 
 
 
Configuration for RouterA:
 
frame-relay switching
!
int s 0
no ip address
frame-relay encapsulation
frame-relay route 167 tun0 43
frame-relay intf-type dce
!
int s 1
ip address 131.108.100.1 255.255.255.0
!
int tu 0
tunnel source serial 1
tunnel destination 131.108.13.2
 
Configuration for RouterB:
 
frame-relay switching
!
int s 0
no ip address
frame-relay encapsulation
frame-relay route 9 tun0 43
frame-relay intf-type dce
!
int s 1
ip address 131.108.13.2 255.255.255.0
!
int tu 0
tunnel source serial 1
tunnel destination 131.108.100.1
 
Channelized E1 Interface Example
 
假设是7500系列路由器,E1接口(MIP板)在插槽4上面.
 
一个channel-group可对应多个时间槽,本例中serial4/0:1有5*64Kbps的数率.
 
Configuration for Router:
 
controller E1 0
framing NO-CRC4
channel-group 0 timeslots 1
channel-group 1 timeslots 2,7-9,20 speed 64
!
interface Serial4/0:0
ip address 16.217.30.2 255.255.255.252
encapsulation ppp
!
interface Serial4/0:1
ip address 16.205.30.5 255.255.255.252
 
X.25 Example
 
在配置X.25时,为减少路由交换引起的呼叫,通常用静态路由.而当一对多情况下,
不在一个子网中用subinterface配置.
 
Configuration for Router:
 
interface serial 0
ip address 131.108.100.1 255.255.255.0
encapsulation x25
x25 address 041673226839
x25 htc 16
x25 map ip 131.108.100.2 041675222222
int s 0.1
ip address 131.108.101.1 255.255.255.0
x25 map ip 131.108.101.2 041674222222
!
ip route 131.108.100.0 255.255.255.0 131.108.100.2
ip route 131.108.101.0 255.255.255.0 131.108.101.2
 关于路由器之间拨号通信的问题
一、 DDN设置
(一)、ROUTER A(CALLER)
Router#
Router#
Router#
Router#
Router#
Router#
Router#sh run
Building configuration...
 
Current configuration:
!
version 11.3
no service password-encryption
!
hostname Router
!
enable secret 5 $1$rAk2$zromrvFspaNC7ICZihqcD/
enable password cisco
!
chat-script config-modem "" ATDT408 TIMEOUT 30 CONNECT /c
!
interface Ethernet0
ip address 132.147.160.111 255.255.255.0
no mop enabled
!
interface Serial0
backup delay 10 10
backup interface Async9
ip address 200.1.1.1 255.255.255.0
encapsulation ppp
no ip mroute-cache
clockrate 64000
!
interface Serial1
no ip address
shutdown
!
interface Async9
ip address 200.2.2.1 255.255.255.0
encapsulation ppp
dialer in-band
dialer map ip 200.2.2.2 modem-script config-modem 408
dialer-group 1
async mode dedicated
!
ip classless
ip route 132.147.161.0 255.255.255.0 200.1.1.2 10
ip route 132.147.161.0 255.255.255.0 200.2.2.2 100
dialer-list 1 protocol ip permit
!
line con 0
line 1 8
line aux 0
modem InOut
flowcontrol hardware
line vty 0 4
password cisco
login
!
end
 
Router#sh line
Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overru
ns
* 0 CTY - - - - - 0 0 0
/0
1 TTY 9600/9600 - - - - - 0 0 0
/0
2 TTY 9600/9600 - - - - - 0 0 0
/0
3 TTY 9600/9600 - - - - - 0 0 0
/0
4 TTY 9600/9600 - - - - - 0 0 0
/0
5 TTY 9600/9600 - - - - - 0 0 0
/0
6 TTY 9600/9600 - - - - - 0 0 0
/0
7 TTY 9600/9600 - - - - - 0 0 0
/0
8 TTY 9600/9600 - - - - - 0 0 0
/0
9 AUX 9600/9600 - inout - - - 0 0 0
/0
10 VTY - - - - - 0 0 0
/0
11 VTY - - - - - 0 0 0
/0
12 VTY - - - - - 0 0 0
/0
13 VTY - - - - - 0 0 0
/0
14 VTY - - - - - 0 0 0
/0
 
Router#sh line aux 0
Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overru
ns
9 AUX 9600/9600 - inout - - - 0 0 0
/0
 
Line 9, Location: "", Type: ""
Length: 24 lines, Width: 80 columns
Baud rate (TX/RX) is 9600/9600, no parity, 2 stopbits, 8 databits
Status: none
Capabilities: Hardware Flowcontrol In, Hardware Flowcontrol Out
Modem Callout, Modem RI is CD, Line is permanent async interface
Modem state: Idle
Modem hardware state: CTS* noDSR noDTR RTS
Special Chars: Escape Hold Stop Start Disconnect Activation
^^x none - - none
Timeouts: Idle EXEC Idle Session Modem Answer Session Dis
patch
00:10:00 never none n
ot set
Idle Session Disconnect Warning
never
Modem type is unknown.
Session limit is not set.
Time since activation: never
Editing is enabled.
History is enabled, history size is 10.
DNS resolution in show commands is enabled
Full user help is disabled
Allowed transports are pad v120 telnet rlogin mop. Preferred is telne
t.
No output characters are padded
No special data dispatching characters
Router#sh s0
^
% Invalid input detected at '^' marker.
 
Router#sh int s0
Serial0 is up, line protocol is up
Hardware is HD64570
Internet address is 200.1.1.1/24
Backup interface Async9, kickin load not set, kickout load not set
failure delay 10 sec, secondary disable delay 10 sec
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, rely 255/255, load 1/2
55
Encapsulation PPP, loopback not set, keepalive set (10 sec)
LCP Open
Open: IPCP, CDPCP
Last input 00:00:02, output 00:00:03, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0 (size/max/drops); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/1 (active/max active/threshold)
Reserved Conversations 0/0/64 (allocated/max allocated)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
49 packets input, 2127 bytes, 0 no buffer
Received 49 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
48 packets output, 1795 bytes, 0 underruns
0 output errors, 0 collisions, 4 interface resets
0 output buffer failures, 0 output buffers swapped out
3 carrier transitions
DCD=up DSR=up DTR=up RTS=up CTS=up
Router#sh int a9
Async9 is standby mode, line protocol is down
Hardware is Async Serial
Internet address is 200.2.2.1/24
MTU 1500 bytes, BW 9 Kbit, DLY 100000 usec, rely 255/255, load 1/255
 
Encapsulation PPP, loopback not set, keepalive not set
DTR is pulsed for 5 seconds on reset
LCP Closed
Closed: IPCP, CDPCP
Last input 00:03:09, output 00:03:22, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0 (size/max/drops); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/1 (active/max active/threshold)
Reserved Conversations 0/0/64 (allocated/max allocated)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
15 packets input, 1184 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
1 input errors, 1 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
66 packets output, 1917 bytes, 0 underruns
0 output errors, 0 collisions, 7 interface resets
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions
Router#!*******************************************************
Router#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state
to down
%LINK-3-UPDOWN: Interface Serial0, changed state to down
%LINK-3-UPDOWN: Interface Async9, changed state to down
Router#sh int a9
Async9 is up (spoofing), line protocol is up (spoofing)
Hardware is Async Serial
Internet address is 200.2.2.1/24
MTU 1500 bytes, BW 9 Kbit, DLY 100000 usec, rely 255/255, load 1/255
 
Encapsulation PPP, loopback not set, keepalive not set
DTR is pulsed for 5 seconds on reset
LCP Closed
Closed: IPCP, CDPCP
Last input 00:06:41, output 00:06:55, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0 (size/max/drops); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/1 (active/max active/threshold)
Reserved Conversations 0/0/64 (allocated/max allocated)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
15 packets input, 1184 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
1 input errors, 1 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
66 packets output, 1917 bytes, 0 underruns
0 output errors, 0 collisions, 7 interface resets
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions
Router#sh int s0
Serial0 is down, line protocol is down
Hardware is HD64570
Internet address is 200.1.1.1/24
Backup interface Async9, kickin load not set, kickout load not set
failure delay 10 sec, secondary disable delay 10 sec
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, rely 255/255, load 1/2
55
Encapsulation PPP, loopback not set, keepalive set (10 sec)
LCP Closed
Closed: IPCP, CDPCP
Last input 00:02:25, output 00:02:25, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0 (size/max/drops); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/1 (active/max active/threshold)
Reserved Conversations 0/0/64 (allocated/max allocated)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
81 packets input, 3189 bytes, 0 no buffer
Received 81 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
81 packets output, 3106 bytes, 0 underruns
0 output errors, 0 collisions, 9 interface resets
0 output buffer failures, 0 output buffers swapped out
4 carrier transitions
DCD=up DSR=up DTR=down RTS=down CTS=up
Router#$************************************************************
Router#ping 132.147.161.111
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 132.147.161.111, timeout is 2 second
s:
.....
Success rate is 0 percent (0/5)
Router#
%LINK-3-UPDOWN: Interface Async9, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Async9, changed state
to up
Router#ping 132.147.161.111
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 132.147.161.111, timeout is 2 second
s:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 376/386/40
4 ms
Router#sh int a9
Async9 is up, line protocol is up
Hardware is Async Serial
Internet address is 200.2.2.1/24
MTU 1500 bytes, BW 9 Kbit, DLY 100000 usec, rely 255/255, load 1/255
 
Encapsulation PPP, loopback not set, keepalive not set
DTR is pulsed for 5 seconds on reset
LCP Open
Open: IPCP, CDPCP
Last input 00:00:10, output 00:00:10, output hang never
Last clearing of "show interface" counters never
Input queue: 1/75/0 (size/max/drops); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/1 (active/max active/threshold)
Reserved Conversations 0/0/64 (allocated/max allocated)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
27 packets input, 2064 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
2 input errors, 2 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
77 packets output, 2514 bytes, 0 underruns
0 output errors, 0 collisions, 7 interface resets
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions
Router#sh int s0
Serial0 is down, line protocol is down
Hardware is HD64570
Internet address is 200.1.1.1/24
Backup interface Async9, kickin load not set, kickout load not set
failure delay 10 sec, secondary disable delay 10 sec
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, rely 255/255, load 1/2
55
Encapsulation PPP, loopback not set, keepalive set (10 sec)
LCP Closed
Closed: IPCP, CDPCP
Last input 00:03:51, output 00:03:51, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0 (size/max/drops); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/1 (active/max active/threshold)
Reserved Conversations 0/0/64 (allocated/max allocated)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
81 packets input, 3189 bytes, 0 no buffer
Received 81 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
81 packets output, 3106 bytes, 0 underruns
0 output errors, 0 collisions, 12 interface resets
0 output buffer failures, 0 output buffers swapped out
4 carrier transitions
DCD=up DSR=up DTR=down RTS=down CTS=up
Router#!**************************************************************
***
%LINK-3-UPDOWN: Interface Serial0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state
to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Async9, changed state
to down
%LINK-5-CHANGED: Interface Async9, changed state to standby mode
Router#ping 132.147.161.111
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 132.147.161.111, timeout is 2 second
s:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/32/32 m
s
Router#sh int s0
Serial0 is up, line protocol is up
Hardware is HD64570
Internet address is 200.1.1.1/24
Backup interface Async9, kickin load not set, kickout load not set
failure delay 10 sec, secondary disable delay 10 sec
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, rely 255/255, load 1/2
55
Encapsulation PPP, loopback not set, keepalive set (10 sec)
LCP Open
Open: IPCP, CDPCP
Last input 00:00:01, output 00:00:01, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0 (size/max/drops); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/1 (active/max active/threshold)
Reserved Conversations 0/0/64 (allocated/max allocated)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
115 packets input, 5131 bytes, 0 no buffer
Received 115 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
115 packets output, 5035 bytes, 0 underruns
0 output errors, 0 collisions, 14 interface resets
0 output buffer failures, 0 output buffers swapped out
13 carrier transitions
DCD=up DSR=up DTR=up RTS=up CTS=up
Router#sh int a9
Async9 is standby mode, line protocol is down
Hardware is Async Serial
Internet address is 200.2.2.1/24
MTU 1500 bytes, BW 9 Kbit, DLY 100000 usec, rely 255/255, load 1/255
 
Encapsulation PPP, loopback not set, keepalive not set
DTR is pulsed for 5 seconds on reset
LCP Closed
Closed: IPCP, CDPCP
Last input 00:01:42, output 00:01:42, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0 (size/max/drops); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/1 (active/max active/threshold)
Reserved Conversations 0/0/64 (allocated/max allocated)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
33 packets input, 2852 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
2 input errors, 2 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
82 packets output, 3019 bytes, 0 underruns
0 output errors, 0 collisions, 8 interface resets
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions
Router#
(二)、ROUTERB (CALLER)
Router#
Router#
Router#
Router#
Router#sh run
Building configuration...
 
Current configuration:
!
version 11.3
no service password-encryption
!
hostname Router
!
enable secret 5 $1$ywCg$Hm9E3ga.xYAbzVTEvPpT3.
enable password cisco
!
!
interface Ethernet0
ip address 132.147.161.111 255.255.255.0
no mop enabled
!
interface Serial0
ip address 200.1.1.2 255.255.255.0
encapsulation ppp
no ip mroute-cache
!
interface Serial1
no ip address
shutdown
!
interface Async1
ip address 200.2.2.2 255.255.255.0
encapsulation ppp
async mode dedicated
pulse-time 60
!
ip classless
ip route 132.147.160.0 255.255.255.0 200.1.1.1
ip route 132.147.160.0 255.255.255.0 200.2.2.1 2
!
line con 0
line aux 0
flowcontrol hardware
line vty 0 4
password cisco
login
!
end
 
Router#sh line aux 0
Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overru
ns
A 1 AUX 9600/9600 - - - - - 0 0 0
/0
 
Line 1, Location: "", Type: ""
Length: 24 lines, Width: 80 columns
Baud rate (TX/RX) is 9600/9600, no parity, 2 stopbits, 8 databits
Status: Ready, Active, Async Interface Active
Capabilities: Hardware Flowcontrol In, Hardware Flowcontrol Out
Line is permanent async interface
Modem state: Ready
Line is running PPP for address 200.2.2.1.
0 output packets queued, 1 input packets.
Async Escape map is 00000000000000000101000000000000
Modem hardware state: CTS* DSR* DTR RTS
Special Chars: Escape Hold Stop Start Disconnect Activation
^^x none - - none
Timeouts: Idle EXEC Idle Session Modem Answer Session Dis
patch
00:10:00 never none n
ot set
Idle Session Disconnect Warning
never
Modem type is unknown.
Session limit is not set.
Time since activation: never
Editing is enabled.
History is enabled, history size is 10.
DNS resolution in show commands is enabled
Full user help is disabled
Allowed transports are pad v120 telnet rlogin mop. Preferred is telne
t.
No output characters are padded
No special data dispatching characters
Router#sh line
Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overru
ns
* 0 CTY - - - - - 0 0 0
/0
A 1 AUX 9600/9600 - - - - - 0 0 0
/0
2 VTY - - - - - 0 0 0
/0
3 VTY - - - - - 0 0 0
/0
4 VTY - - - - - 0 0 0
/0
5 VTY - - - - - 0 0 0
/0
6 VTY - - - - - 0 0 0
/0
 
Router#sh int s0
Serial0 is up, line protocol is up
Hardware is HD64570
Internet address is 200.1.1.2/24
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, rely 255/255, load 1/2
55
Encapsulation PPP, loopback not set, keepalive set (10 sec)
LCP Open
Open: IPCP, CDPCP
Last input 00:00:05, output 00:00:05, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0 (size/max/drops); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/1 (active/max active/threshold)
Reserved Conversations 0/0/64 (allocated/max allocated)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
74 packets input, 2733 bytes, 0 no buffer
Received 74 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
75 packets output, 3093 bytes, 0 underruns
0 output errors, 0 collisions, 4 interface resets
0 output buffer failures, 0 output buffers swapped out
3 carrier transitions
DCD=up DSR=up DTR=up RTS=up CTS=up
Router#sh int a1
Async1 is up, line protocol is up
Hardware is Async Serial
Internet address is 200.2.2.2/24
MTU 1500 bytes, BW 9 Kbit, DLY 100000 usec, rely 255/255, load 1/255
 
Encapsulation PPP, loopback not set, keepalive not set
DTR is pulsed for 60 seconds on reset
LCP Open
Open: IPCP, CDPCP
Last input 00:05:23, output 00:00:10, output hang never
Last clearing of "show interface" counters never
Input queue: 1/75/0 (size/max/drops); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/1 (active/max active/threshold)
Reserved Conversations 0/0/64 (allocated/max allocated)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
33 packets input, 1125 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
31 packets output, 2888 bytes, 0 underruns
0 output errors, 0 collisions, 2 interface resets
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions
Router#!**************************************************************
 
Router#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state
to down
%LINK-3-UPDOWN: Interface Serial0, changed state to down
Router#sh int a9
^
% Invalid input detected at '^' marker.
 
Router#sh int a1
Async1 is up, line protocol is up
Hardware is Async Serial
Internet address is 200.2.2.2/24
MTU 1500 bytes, BW 9 Kbit, DLY 100000 usec, rely 255/255, load 1/255
 
Encapsulation PPP, loopback not set, keepalive not set
DTR is pulsed for 60 seconds on reset
LCP Open
Open: IPCP, CDPCP
Last input 00:07:20, output 00:00:07, output hang never
Last clearing of "show interface" counters never
Input queue: 1/75/0 (size/max/drops); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/1 (active/max active/threshold)
Reserved Conversations 0/0/64 (allocated/max allocated)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
33 packets input, 1125 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
33 packets output, 3454 bytes, 0 underruns
0 output errors, 0 collisions, 2 interface resets
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions
Router#wr
Building configuration...
[OK]
Router#sh int s0
Serial0 is down, line protocol is down
Hardware is HD64570
Internet address is 200.1.1.2/24
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, rely 255/255, load 1/2
55
Encapsulation PPP, loopback not set, keepalive set (10 sec)
LCP Closed
Closed: IPCP, CDPCP
Last input 00:02:15, output 00:02:15, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0 (size/max/drops); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/1 (active/max active/threshold)
Reserved Conversations 0/0/64 (allocated/max allocated)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
81 packets input, 3106 bytes, 0 no buffer
Received 81 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
81 packets output, 3189 bytes, 0 underruns
0 output errors, 0 collisions, 9 interface resets
0 output buffer failures, 0 output buffers swapped out
4 carrier transitions
DCD=down DSR=down DTR=up RTS=up CTS=down
Router#!************************************************************
Router#sh int a1
Async1 is up, line protocol is up
Hardware is Async Serial
Internet address is 200.2.2.2/24
MTU 1500 bytes, BW 9 Kbit, DLY 100000 usec, rely 255/255, load 1/255
 
Encapsulation PPP, loopback not set, keepalive not set
DTR is pulsed for 60 seconds on reset
LCP Open
Open: IPCP, CDPCP
Last input 00:00:35, output 00:00:35, output hang never
Last clearing of "show interface" counters never
Input queue: 1/75/0 (size/max/drops); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/1 (active/max active/threshold)
Reserved Conversations 0/0/64 (allocated/max allocated)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
44 packets input, 1722 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
46 packets output, 4617 bytes, 0 underruns
0 output errors, 0 collisions, 2 interface resets
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions
Router#sh int s0
Serial0 is down, line protocol is down
Hardware is HD64570
Internet address is 200.1.1.2/24
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, rely 255/255, load 1/2
55
Encapsulation PPP, loopback not set, keepalive set (10 sec)
LCP Closed
Closed: IPCP, CDPCP
Last input 00:04:17, output 00:04:17, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0 (size/max/drops); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/1 (active/max active/threshold)
Reserved Conversations 0/0/64 (allocated/max allocated)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
81 packets input, 3106 bytes, 0 no buffer
Received 81 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
81 packets output, 3189 bytes, 0 underruns
0 output errors, 0 collisions, 13 interface resets
0 output buffer failures, 0 output buffers swapped out
4 carrier transitions
DCD=down DSR=down DTR=up RTS=up CTS=down
Router#ping 200.2.2.1
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 200.2.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 380/387/40
8 ms
Router#!**************************************************************
******
Router#
%LINK-3-UPDOWN: Interface Serial0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state
to up
Router#sh int a1
Async1 is up, line protocol is up
Hardware is Async Serial
Internet address is 200.2.2.2/24
MTU 1500 bytes, BW 9 Kbit, DLY 100000 usec, rely 255/255, load 1/255
 
Encapsulation PPP, loopback not set, keepalive not set
DTR is pulsed for 60 seconds on reset
LCP Open
Open: IPCP, CDPCP
Last input 00:00:54, output 00:00:54, output hang never
Last clearing of "show interface" counters never
Input queue: 1/75/0 (size/max/drops); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/1 (active/max active/threshold)
Reserved Conversations 0/0/64 (allocated/max allocated)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
49 packets input, 2227 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
52 packets output, 5405 bytes, 0 underruns
0 output errors, 0 collisions, 2 interface resets
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions
Router#sh int s0
Serial0 is up, line protocol is up
Hardware is HD64570
Internet address is 200.1.1.2/24
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, rely 255/255, load 1/2
55
Encapsulation PPP, loopback not set, keepalive set (10 sec)
LCP Open
Open: IPCP, CDPCP
Last input 00:00:00, output 00:00:00, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0 (size/max/drops); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/1 (active/max active/threshold)
Reserved Conversations 0/0/64 (allocated/max allocated)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
97 packets input, 3606 bytes, 0 no buffer
Received 97 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
98 packets output, 3979 bytes, 0 underruns
0 output errors, 0 collisions, 14 interface resets
0 output buffer failures, 0 output buffers swapped out
7 carrier transitions
DCD=up DSR=up DTR=up RTS=up CTS=up
Router#ping 200.1.1.1
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 200.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/32/32 m
s
Router#
(三)、Hayes modem的设置
1、RouterA(caller)
 
at
OK
at&v
ACTIVE PROfile: B1 B16 B30 B41 B52 B60 B70 B75 B80 E1 L2 M1 N1 P Q0 V1
W0 X4
Y0 &A0 &B1 &C1 &D3 &G0 &K3 &L0 &Q5 &R0 &S0 &T4 &U0 &X0 &Y0 S00:00
0 S02:043
S03:013 S04:010 S05:008 S06:002 S07:050 S08:002 S09:006 S10:014 S11:09
5 S12:050
S25:005 S26:001 S36:007 S37:000 S38:020 S46:002 S48:007
 
STORED PROFILE 0: B1 B16 B30 B41 B52 B60 B70 B75 B80 E1 L2 M1 N1 P Q0
V1 W0 X4
Y0 &A0 &B1 &C1 &D3 &G0 &K3 &L0 &Q5 &R0 &S0 &T4 &U0 &X0 S00:000 S02:04
3 S06:002
S07:050 S08:002 S09:006 S10:014 S11:095 S12:050 S25:005 S26:001 S36:00
7 S37:000
S38:020 S46:002 S48:007 S108:001
 
STORED PROFILE 1: B1 B16 B30 B41 B52 B60 B70 B75 B80 E1 L2 M1 N1 P Q0
V1 W0 X4
Y0 &A0 &B1 &C0 &D0 &G0 &K3 &L0 &Q5 &R0 &S0 &T4 &U0 &X0 S00:000 S02:04
3 S06:002
S07:050 S08:002 S09:006 S10:014 S11:095 S12:050 S25:005 S26:001 S36:00
7 S37:000
S38:020 S46:002 S48:007 S108:001
 
TELEPHONE NUMBERS:
&Z0=402
&Z1=
&Z2=
&Z3=
 
OK
AT&FS0=1&C1&D3&W
2、RouterB(Server中心)
at&fe0q1&w或
at&fs0=1&d3&w
 Cisco HSRP的配置
发信人: ymllb (), 信区: CISCO
标? 题: Cisco HSRP的配置
发信站: 网易虚拟社区 (Wed Jun 16 13:15:55 1999), 站内信件


version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r1
!
enable password cisco
!
ip subnet-zero
!
?!
?!
?!
?interface Ethernet0
?ip address 136.147.107.101 255.255.0.0
?no ip redirects
?no ip directed-broadcast
?standby 150 timers 5 15?? /* 定义150组5秒交换一次hello信息,15秒没收到
hello信息就开始切换 */
?standby 150 priority 110 /* 定义150组的主路由器权值,值越大,为主路由
器希望越大 */
?standby 150 preempt /* enable 150组的hsrp抢占功能 */
?standby 150 authentication cisco? /* 设置150组的router身份验证串 */
?standby 150 ip 136.147.107.100 /* 定义150组的浮动地址,也是这台router
连接的网络的网关 */
?standby 150 track Ethernet0 /* 定义监控的端口 */
!
interface Serial0
?no ip address
?no ip directed-broadcast
?no ip mroute-cache
?shutdown
?no fair-queue
!
ip classless
!
!
line con 0
?transport input none
line 1 16
line aux 0
line vty 0 4
?password cisco
?login
!
end
cisco NAT 的配置例子
发信人: ymllb (), 信区: CISCO
标? 题: cisco NAT 的配置例子
发信站: 网易虚拟社区 (Wed Jun 16 13:12:24 1999), 站内信件

!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname nat-r1
!
enable secret 5 $1$FEQr$INhRecYBeCb.UqTQ3b9mY0
!
ip subnet-zero
!
?!
?!
?!
?interface Ethernet0
?ip address 172.18.150.150 255.255.0.0
?no ip directed-broadcast
?ip nat inside??????????? /* 定义此为网络的内部端口 */
!
interface Serial0
?ip address 192.1.1.161 255.255.255.252
?no ip directed-broadcast
?ip nat outside??? /*? 定义此为网络的外部端口 */

?no ip mroute-cache
?no fair-queue
!
interface Serial1
?no ip address
?no ip directed-broadcast
?shutdown
!??????? /* 定义从ISP那里申请到的IP在企业内部的分配策阅 */
ip nat pool tech 192.1.1.100 192.1.1.120 netmask 255.255.255.0
ip nat pool deve 192.1.1.121 192.1.1.150 netmask 255.255.255.0
ip nat pool manager 192.1.1.180 192.1.1.200 netmask 255.255.255.0
ip nat pool soft-1 192.1.1.170 192.1.1.179 netmask 255.255.255.0
ip nat pool soft-2 192.1.1.151 192.1.1.159 netmask 255.255.255.0
ip nat pool temp-user 192.1.1.160 192.1.1.160 netmask 255.255.255.0
??????? /* 将访问列表与地址池对应,以下为动态地址转换*/
ip nat inside source list 1 pool tech
ip nat inside source list 2 pool deve
ip nat inside source list 3 pool manager
ip nat inside source list 4 pool soft-1
ip nat inside source list 5 pool soft-2
???????????? /*?? 将访问列表与地址池对应,以下为复用动态地址转换*/
ip nat inside source list 6 pool temp-user overload
???????????? /*?? 将访问列表与地址池对应,以下为静态地址转换*/?????
ip nat inside source static 172.18.100.168 192.1.1.168
ip nat inside source static 172.18.100.169 192.1.1.169
ip classless?
ip route 0.0.0.0 0.0.0.0 Serial0?????? /* 设置一个缺省路由 */
!??????????? /* 内部网访问地址表,他指出内部网络能访问外部网的地址段,
分别定义是为了对应
???????????????????? 不同的地址池? */
access-list 1 permit 172.18.107.0 0.0.0.255
access-list 2 permit 172.18.101.0 0.0.0.255
access-list 3 permit 172.18.108.0 0.0.0.255
access-list 4 permit 172.18.103.0 0.0.0.255
access-list 4 permit 172.18.102.0 0.0.0.255
access-list 4 permit 172.18.104.0 0.0.0.255
access-list 5 permit 172.18.105.0 0.0.0.255
access-list 5 permit 172.18.106.0 0.0.0.255
access-list 6 permit 172.18.111.0 0.0.0.255
!
line con 0
?transport input none
line 1 16
line aux 0
line vty 0 4
?login
!
end

阅读全文
0 0

相关文章推荐

img
取 消
img