CSDN博客

img youlin

[原]配置Eclipes的J2ME开发环境(Windows下) 选择自 clapton 的 Blog

发表于2004/10/10 0:16:00  1130人阅读

 

clapton_xpAThotmailDOTcom

 

一、文件下载

l         Eclipes (3.0): http://www.eclipse.org/downloads/index.php

l         Eclipesme (0.46): http://eclipseme.sourceforge.net/

l         j2me Wireless Toolkit (2.2beta): http://java.sun.com/products/j2mewtoolkit/download-2_2.html

l         J2SE SDK (1.4.2): http://java.sun.com/j2se/1.4.2/download.html

l         ProGuard (2.1): http://proguard.sourceforge.net

 

二、安装

l         安装JDK1.4.2 (WTK2.2要求1.4.2以上)

l         安装WTK

l         安装Eclipes

l         解压缩EclipesmeEclipesplugin目录

clapton_xpAThotmailDOTcom

三、开发与配置

l         EclipseWindow->Perferences->J2ME->Platform Components->Wireless Toolkit下添加指定的WTK,目前支持的包括SunWTKNokiaNDSSonyEricssonSDK

l         新建一个工程,可以选New->Other->J2ME->J2ME Midlet Suite

l         基本上都是默认的,确定之后,在工程上右键New->Source Folder ,起名叫“src  以后的源码都放在src这个目录里。这样做的目的可以防止打包时子目录的文件被强行放置在根目录里。

l         编写,保存的时候会自动编译。

l         打包:工程上右键->J2ME->Create Package 搭出的包在deployed目录下

l         打混淆包:需先配置ProguardWindow->Perferences->J2ME->Platform Components->Obfuscation 选择Proguard路径 另外建议use specified arguments:“-dontusemixedcaseclassnames”否则在windows下有可能产生大小写的混乱。配置好后,工程上右键->J2ME->Create Obfuscated Package

 

四、FAQ

l         打好的包模拟器可以运行,但是通过OTA下载时显示“无效文件”。解决办法:将打包时生成的JAD文件的换行符改为Unix换行符(可用UltraEditFile->Conversions)。

l         待添加。。。


阅读全文
0 0

相关文章推荐

img
取 消
img